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Introduction

The PLC Pixsys PL500/PLE500 range features a modular and flexible structure.
The PL500 CPU is a control unit and connectivity node, complete with serial RS485 and RS232 (Modbus
RTU), Ethernet (Modbus TCP/IP) and CanOpen and is based on an ARM CORTEX A8 -1 GHz microprocessor.
The various combinations of analogue-digital I/O instead reside on the PLE500 modules, which
communicate via real-time internal Bus on DIN-rail.
The LogicLab development environment is available in order to program the logic and can be
downloaded from the dedicated area at www.pixsys.net.

1

Safety guidelines

1.1

Organization of safety notices

1.2

Safety Precautions

Read carefully the safety guidelines and programming instructions contained in this manual before
connecting/using the device.
Disconnect power supply before proceeding to hardware settings or electrical wirings to avoid risk of
electric shock, fire, malfunction.
Do not install/operate the device in environments with flammable/explosive gases.
This device has been designed and conceived for industrial environments and applications that rely
on proper safety conditions in accordance with national and international regulations on labour
and personal safety. Any application that might lead to serious physical dama ge/ life risk or involve
medical life support devices should be avoided.
Device is not conceived for applications related to nuclear power plants, weapon systems, flight
control, mass transportation systems.
Only qualified personnel should be allowed to use device and/or service it and only in accordance to
technical data listed in this manual.
Do not dismantle/modify/repair any internal component.
Device must be installed and can operate only within the allowed environmental conditions.
Overheating may lead to risk of fire and can shorten the lifecycle of electronic components.

Safety notices in this manual are organized as follows:
Safety notice
Description
Danger!
Disregarding these safety guidelines and notices can be life-threatening.
Disregarding these safety guidelines and notices can result in severe injury or
Warning!
substantial damage to property.
Information! This information is important for preventing errors.

Danger!

Danger!

Warning!
Warning!

CAUTION - Risk of Fire and Electric Shock
This product is UL listed as Open Type Process Control Equipment. It must be
mounted in an enclosure that does not allow fire to escape externally.
If the output relays are used past their life expectancy, contact fusing or burning may
occasionally occur.
Always consider the application conditions and use the output relays within their
rated load and electrical life expectancy. The life expectancy of output relays varies
considerably with the output load and switching conditions.
Devices shall be supplied with limited energy according to UL 61010-1 3rd Ed, section
9.4 or LPS in conformance with UL 60950-1 or SELV in conformance with UL 60950-1
or Class 2 in compliance with UL 1310 or UL 1585.
Loose screws may occasionally result in fire.
For screw terminals, tighten screws to tightening torque of 0.5 Nm
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A malfunction in the Digital Controller may occasionally make control operations
impossible or prevent alarm outputs, resulting in property damage. To maintain
safety in the event of malfunction of the Digital Controller, take appropriate safety
measures, such as installing a monitoring device on a separate line.

Warning!

1.3

Precautions for safe use

Be sure to observe the following precautions to prevent operation failure, malfunction, or adverse
affects on the performance and functions of the product. Not doing so may occasionally result in
unexpected events. Do not handle the Digital Controller in ways that exceed the ratings.
• The product is designed for indoor use only. Do not use or store the product outdoors or in any of
the following places.
- Places directly subject to heat radiated from heating equipment.
- Places subject to splashing liquid or oil atmosphere.
- Places subject to direct sunlight.
- Places subject to dust or corrosive gas (in particular, sulfide gas and ammonia gas).
- Places subject to intense temperature change.
- Places subject to icing and condensation.
- Places subject to vibration and large shocks.
• Installing two or more controllers in close proximity might lead to increased internal temperature
and this might shorten the life cycle of electronic components. It is strongly recommended to
install cooling fans or other air-conditioning devices inside the control cabinet.
• Always check the terminal names and polarity and be sure to wire properly. Do not wire the
terminals that are not used.
• To avoid inductive noise, keep the controller wiring away from power cables that carry high voltages
or large currents. Also, do not wire power lines together with or parallel to Digital Controller
wiring. Using shielded cables and using separate conduits or ducts is recommended. Attach a
surge suppressor or noise filter to peripheral devices that generate noise (in particular motors,
transformers, solenoids, magnetic coils or other equipment that have an inductance component).
When a noise filter is used at the power supply, first check the voltage or current, and attach the
noise filter as close as possible to the Digital Controller. Allow as much space as possible between
the Digital Controller and devices that generate powerful high frequencies (high-frequency
welders, high-frequency sewing machines, etc.) or surge.
• A switch or circuit breaker must be provided close to device. The switch or circuit breaker must be
within easy reach of the operator, and must be marked as a disconnecting means for the controller.
• The device must be protected by a fuse 5A (cl. 9.6.2).
• Wipe off any dirt from the Digital Controller with a soft dry cloth. Never use thinners, benzine,
alcohol, or any cleaners that contain these or other organic solvents. Deformation or discoloration
may occur.
• The number of non-volatile memory write operations is limited. Therefore, use EEprom write mode
when frequently overwriting data, e.g.: through communications.

1.4

Environmental policy / WEEE

Do not dispose electric tools together with household waste material.
According to European Directive 2012/19/EU on waste electrical and electronic equipment and its
implementation in accordance with national law, electric tools that have reached the end of their life
must be collected separately and returned to an environmentally compatible recycling facility.
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2

Model identification

3
3.1

Technical data
General characteristics

The PL500 series comes in 2 versions:
PL500-335-1AD
PLC DIN Rail 1 Ethernet, 1 RS485, 1 RS232, 1 CANopen
PLC DIN Rail 1 Ethernet, 1 RS485, 1 RS232, 1 CANopen Movicon
PL500-335-1AD-WEB
Webserver

Supply voltage
Consumption (max. Use with 1
USB device)
Operating conditions
Container

12..24 VDC ± 10%
5W
Temperature: 0-45°C; humidity 35..95 RH% without condensation
DIN43880, 54 x 90 x 64 mm
Container: PC UL94V0 self-extinguishing
Front panel: PC UL94V0 self-extinguishing
IP20 (container and terminals)
Approximately 130 g

Materials
Protection
Weight

3.2

Hardware characteristics

CPU
RAM
eMMC

Software characteristics
PL500-335-1AD
5mS
10,000 words
10,000 words
unlimited
unlimited

Minimum cycle time
No. of non retentive words
No. of retentive words
Timer, meter, PID functions
PLC code size

Dimension and installation
USB1

CN3

54 mm (3 moduli DIN)

64 mm

CN2

90 mm

4

PL500-335-1AD-WEB
10mS

CN1

3.3

ARM® CORTEX™ - A8 @1.0GHz
512 MB DDR3
4GB for PLC code and retentive memories

DP1

Attacco a guida DIN EN50022
Din rail mounting guide EN50022
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4.1

Mounting sequence of the PL500 and of the PLE500
expansion modules

The PL500 with the relevant I/O modules requires mounting and connection via the specific bus
lodged in the hollow of the DIN rail. The I/O modules (series PLE500-xAD) will be automatically
numbered at each power-on, assigning the number 1 to the first I/O module connected to the right
of the PL500, the number 2 to the following one and so on, always moving towards the right side.
The position of the various modules shall thus reflect the sequence set in the LogicLab project in the
definition of the PLCEXP network. For the numbering procedure to work correctly, it is not permitted
to remove devices from the network by releasing them from their own bus and leaving some empty
modules (bus slots) between one module and another. All connection/disconnection operations must
be carried out with power off.
Couple all the buses by pushing them towards the DIN
rail, making sure that the male connection faces left
and the female one faces right.

Clik!

Couple the buses together by sliding them along the
DIN rail.

Insert the various modules in the slots of the buses
starting from the PL500 and continuing to the right
with the I/O modules.
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It is not possible to leave free slots in the bus between
one module and another.
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3

5

Electric connections

5.1

Wiring diagram
CN1

CN3

USB1

This instrument was designed and built in compliance with the Low Voltage Directives 2006/95/
CE, 2014/35/EU (LVD) and Electromagnetic compatibility 2004/108/EC and 2014/30/EU (EMC). For
installation in industrial environments it is a good rule to follow the precautions below:
• Distinguish the power supply line from the power lines.
• Avoid the proximity with contactor units, electromagnetic contactors, high power motors and use
filters in any event.
• Avoid the proximity with power units, particularly with phase control.
• The use of network filters is recommended on the power supply of the machine in which the
instrument will be installed, particular in case of 230 VAC power supply.
The instrument is devised to be assembled with other machines. Therefore, the EC marking of
the instrument does not exempt the manufacturer of the system from the safety and conformity
obligations imposed for the machine as a whole.
• Wiring of pins use crimped tube terminals or flexible/rigid copper wire with diameter 0.25 to 1.5
mm2 (min. AWG28, max. AWG16, operating temperature: min. 70°C). Cable stripping lenght 7 to 8
mm.

CN2

PL500-335-1AD

DP1

1

2
SUPPLY
12..24Vdc

5.1.b

3

4

Power supply
3
12..24 VDC ± 10%

CAN1 serial
5
6
4

CANH CANL
5.1.c

3

9

C

3 2 1

ON OFF

5.1.a

CAN MASTER:
120Ω terminator
Connect any shield of the cable to terminal 3.

RS232 / COM1 serial
10 11
Connect any shield of the cable to terminal 3.

TXD RXD

C
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5.1.e

6

7

8

4 3 2 1

C

A-

B+

4 3 2 1

ON OFF

3

RS485 MASTER:
120Ω terminator
470Ω polarizer

ON OFF

4 3 2 1

RS485 MASTER:
470Ω polarizer only

ON OFF

RS485 / COM2 serial

5.1.d

RS485 SLAVE:
120Ω terminator only

Ethernet
10/100 Mbit Ethernet port to program the development software and
network connectivity.

5.1.f

PLE / DIN bus
Bus connector to be lodged in the hollow of the DIN rail to connect any I/O
module to the PL500. For the mounting sequence see paragraph 1.2.

5.1.g

USB
USB 2.0 port for Backup / Restore of the mass archiving functionalities and
applications (the memory must be formatted in FAT/FAT32).
Micro SD slot (internal)
MicroSD slot for Backup / Restore of applications and mass archiving
functionalities (the memory must be formatted in FAT/FAT32). The Boot
function from MicroSD is possible by positioning the DIP 4 of the external Dip
switch on ON.

4 3 2 1

5.1.i

ON OFF

5.1.h

S1 button for system Backup / Restore (internal)
Backup:
1 Insert a MicroSD (internal) or USB (external) memory.
2 Position the “Stop” DIP to ON and turn the PLC on by pressing the button
(the internal green LED turns on).
3 Wait for the completion of the Backup procedure (the internal green LED
turns off).
4 Turn the PLC off, remove the MicroSD or USB memory and turn the device
on again.
Restore:
1 Insert a MicroSD or USB memory containing the Backup.
2 Position the “Stop” DIP to OFF and turn the PLC on by pressing the button
(the internal green LED turns on).
3 Wait for the completion of the Backup procedure (the internal green LED
turns off).
4 Turn the PLC off, remove the MicroSD or USB memory and turn the device
on again.
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IP address
ON

DIP switch settings (internal)

6.a
1 2 3 4

6

STOP
To interrupt the running of the PLC program.

1 2 3 4

ON

1 2 3 4

ON

1 2 3 4

ON

1 2 3 4

ON

192.168.0.ID
• If set to ON, force the first part of the IP address of the PLC to “192.168.0.”,
then allow the last part of the address to be assigned through two internal
rotary-switches IDX10 and IDX1.
• If set to OFF (default position) the IP address is 192.168.0.99 (or the last one
manually assigned using the TdControlPanel for the version PL500-3351AD-WEB).
DHCP
If set to ON, force the assignment of the IP address of the PLC through the
DHCP function; as a result, this service must be enabled in the network where
the device resides.

6.b

Battery (internal)
The battery allows the system clock of the PLC to be kept active also without
power.
When flat, the original battery can be replaced with a standard battery of the
CR2032 type.

Condition not available yet.

CR 2032
+

6.1

BATT
If set to ON, it inserts the battery in the circuit of the internal clock. This DIP
must remain on ON to maintain the system clock active also without power.

Meaning of the status lights (LED)

Fixed on indicates the normal operation of the PLC.
Flashing in flash mode every 1 s indicates that the device is still in the initialization
phase and the PLC has not started yet (STOP LED on).
EXP
The LED indicates that the PLC program requires the use of the PLCEXP expansion bus
CAN1 The LED indicates that the PLC program requires the use of the CAN1 bus
COM1 The LED indicates that the PLC program requires the use of the COM1 serial line
COM2 The LED indicates that the PLC program requires the use of the COM2 serial line
COM3 The LED indicates that the PLC program requires the use of the COM3 serial line
ETH1
The LED indicates the presence of activity on the ETH1 network
ETH2
The LED indicates the presence of activity on the ETH2 network
WIFI
The LED indicates the presence of activity on the wi-fi network
STOP
The LED on indicates that the PLC is in the STOP status
E.BATT The LED on indicates that the battery of the clock is flat and must be replaced
The LED on indicates an anomaly on the PLCEXP expansion bus (missing/faulty
E.EXP
modules or modules that do not match the program being run)
The LED on indicates that one or more analogue inputs of the PLCEXP bus modules is
E.AI
out of range
E.1
The LED on indicates a software/hardware error in the PLCEXP bus expansion modules
E.2
The LED on indicates that the PLC is in software/hardware error
DHCP The LED on indicates that the IP address of PLC is assigned automatically by the DHC
SD HC The LED indicates that the PLC is set to BOOT from SD memory (dip SD on ON)
RUN
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Graphic interface – Webserver function

8

TdControlPanel

In the PL500-335-1AD-WEB version, the PL500 PLC makes a graphic interface available, with the
possibility of developing synoptics with the Movicon 11 CE scada, such as the HMI terminals of the
TD710, TD810, TD820 series.
The graphic interface can be accessed through any “VNC client” program connected to the IP address
assigned by the internal dip-switches (see paragraph 6.a). This interface lets you access the TdControlPanel (common to HMIs) and thus configure the start of the Movicon 11 scada and of the Webserver
function.
The Webserver function lets you access Movicon synoptics developed by the user from any Internet
browser with Java service active (the use of the “Internet Explorer” browser is advised) or with the
dedicated App, available for Android and iOS devices.

When starting the device, a project opens that allows you
to verify the general status of the machine, system date
and time, associated IP address, SoftPLC running in the
background.

Using a VNC client you can view from your PC what is displayed on the PLC/HMI. When you start a
browser with Java service active you can also test whether the Webserver function of the device is
active. You need to use the Internet Explorer browser for this function.
Use the “Td Control Panel” button to access the device
control panel, where you can verify and configure the
various services and projects to be launched upon start up,
in addition to the possibility of configuring the wait time
before back lighting turns off, the buzzer upon touching
the display, etc.
The paragraph below describes each function of the windows in the TdControlPanel.
NB: The pictures show the device default configuration.
8.a

WIN EXPLORER
This window lets you choose a set of options for Windows
CE start modes and the running of the TDControlPanel.
• The first option starts Windows CE with desktop.
• The second options lets you start the TDControlPanel if,
during terminal start-up, the button “Stop” is held down
.
• Enable the third option to set a protection password
and avoid unauthorized users accessing the TDControlPanel settings, holding the “STOP” button down .

The “START WINDOWS DESKTOP” buttons lets you start the “Explorer.exe” service and access Windows
CE desktop.
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8.b

HMI_MOVICON
Use this window to select the services and programs
relating to Movicon 11 to be run automatically when
starting the device.
The functions of the Movicon scada are available in all
the HMIs and in the PL500 in the “WEB” version (PL500335-1AD-WEB)

The “START” button starts the Movicon project (and the file upload service) manually.
8.c

PLC LOGICLAB

Use this window to enable/disable the running of the
SoftPLC when starting the device. When you select the
“RUN console DEBUG” flag while running the SoftPLC, the
Debug window will be compiled with the system events in
real time to be able to check any anomalies.
NB: this function requires many resources from the device.
You are advised to keep it active only if you experience
problems while developing the software. You are
recommended to disable it at the end of the development
phase!
The “START” button starts the SoftPLC project (and any debut window) manually.
8.d

LAN ETH1
Use this window to change the network configuration
parameters of the device. Restart for any change to be
applied.
NB: for the SoftPLC and Movicon program to be
transferred to the device, this must have a fixed address
as it is not possible to work in DHCP.
The default IP address of the HMIs is 192.168.0.100
The default IP address of the PL500 is 192.168.0.99

8.e

BACKLIGHT - BUZZER
Use this window to configure the parameters regarding the
backlight and the buzzer. When the “Always ON” function is
enabled the backlight remains always on, otherwise enter
the time in seconds to start the power off or dimming of
the light in the third field “Backlight ON for..(sec)” Use
the 1st and 2nd field to set: the brightness (100% = one,
0%=off) in normal operating conditions and in standby.
The forth field “Buzzer frequency” lets you set the frequency
of the buzzer sound: the higher the frequency the more
piercing the sound. The “Buzzer OFF” flag disables the
buzzer during the touch. The “TEST” buttons let you test
the set parameters before saving the configuration.
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8.f

WINVNC
Use this window to enable/disable the VNC remote
Desktop service. The “START VNC” button enables this
service manually. The “START VNC_CONFIG” button opens
the VNC configuration window to set the authentication
system, change the access password, etc. Be warned
that the change of parameters is advised for advances
users, the incorrect change of the parameters will cause
the remote desktop service to malfunction. The default
password to access the remote Desktop of the device via
VNC is “1234”.

9

Suite LogicLab

Suite LogicLab is Pixsys development environment to program the PLC PL500 and the entire family of
operator terminals and PanelPCs.
The suite can be downloaded from the download area of the pixsys.net website after having registered
and does not require any activation code. It is compatible with all Windows 32/64bit versions starting
from Windows XP SP3 and is available in English and Italian. Once you download the setup file on
your computer, start the installation and follow the standard procedure. Once the program has been
installed, it is started through the ”LogicLab” item on the desktop or from the “Start” > “PixsysSuite”
> “LogicLab” menu.
9.a

Language change
To change the language displayed you need
to open the options window from the “File” >
“Options” menu, move to the “Language” tab,
select the item “ITA - italiano” and press “Select”.
Confirm with “OK” and finally close and open
LogicLab for the changes to take effect.

9.b

Creating - loading a project
Opening an existing project:
• With LogicLab aperto, click the “Open project”
button or select one of the last opened
projects from the proposed list.
• With LogicLab closed, enter the project folder
and double click on the file with the name of
the desired project, which will have the icon
and extension “.plcprj”.
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Creating a new project:
Press the “New project” button.
In the appearing window enter a name for the
project and identify the folder where the project
files must be inserted. Finally select the device
you wish to program.

Warning: when selecting the “case sensitive” flag, a variable that contains a capital letter will be meant
as different from another same one but with this as a lower-case letter. We suggest that you leave this
selection disabled to avoid any confusion while drafting the program code.
9.c
Connection to the target
Listed below are the requirements needed for the correct connection between the target (device to
be programmed) and the development environment on PC (LogicLab).
Requirements to be checked on the target:
• device on and started
• configured with static IP address compatible with the network where it resides and the PC with
which it must connect. By default, the IP address of the HMI terminals is 192.168.0.100, that of the
PL500 is 192.168.0.99; therefore, the PC with the development must have the same network and
class (192.168.0.XXX in this case) but a different physical address (i.e. the last 3 digit of the IP address,
with any number ranging between 1 and 255, other than 100). If you need to change the IP address
of the terminal in relation to the default, please refer to the configuration of the TD Control Panel,
“LAN ETH1” section under par. 8.d.
• connection with (direct or cross) network cable directly to the PC or through a network switch
• SoftPLC running (for this refer to the TD Control Panel configuration, “PLC LOGICLAB” section under
par. 8.c).

Requirements to be checked on the development PC:
• IP address compatible with the existing network where it resides and with the IP address configured
in the target (see previous points)
• anti-virus/firewall that allows the connection to network devices (they are usually already correctly
configured)
• LogicLab configured to connect to the connected target you want to program: to do this, browse
the “On Line” > “set communication” menu and in the appearing window press the “Properties” button
and then under the “IP Address” item enter the IP address of the target, leaving everything else
unchanged. In case of very slow networks or of a network configuration with different switches, the
“Timeout” value (expressed in mS) may be increased.

The image shows the default configuration

Confirm all the windows pressing “OK” and save using the
menu.

icon or through the “file” > “Save Project”
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At this point, to check that the configuration of the LogicLab and the target is correct, connect by
pressing the
icon or from the “On Line” > “Connect” menu. If the connection is successful the status
bar in the bottom right will show “CONNECTED” and “NO CODE” to indicate that the target is connected
and has no code inside it, or “DIFF CODE” to indicate that the code displayed does not match the one
residing in the target.

9.d
Compiling and downloading the code
Once the project code has been entered, you need to compile it to make sure there are no errors,
pressing F7, through the
icon or the “Project” > “Compile” menu.
If compiling is successful you can transfer the program to the target pressing F5, through the
icon
or from the “On Line” > “Code transfer” menu.
At this point the status bar will show “CONNECTED” and “SOURCE OK” indicating that the program being
run in the target corresponds to the one being displayed on the PC.

9.e
The watch window
If the program being run in the target matches the one being displayed on the PC, the status bar
shows “CONNECTED” and “SOURCE OK” and it is thus possible to use the “Watch” window to check the
status of the variables used in the project in real time. Enable the “Watch” window by pressing the
CTRL+T buttons or use the “View” > “Instrument window” > “Watch” menu. To add a variable to the
“Watch” window simply drag it inside it or press the
icon and select it manually.

From this moment on the “Watch” window
will start to display the value of the entered
variable, in real time.
Use the specific buttons
of variables.

to save, download and add an already existing watch-list to the list

If you wish to change the display format simply select the
variable and press the icon . From the appearing window
select the desired format and confirm with “OK”.
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Interfacing Movicon 11 with LogicLab

NB: Movicon 11.5 or above is required.

To do only the first time:
In the PC with the development, copy the “Drivers.xml” and “Pixsys.dll” files in
C:\Program Files (x86)\Progea\Movicon11.5\Drivers overwriting those present.
If you are using a Panel PC (TD750-TD850-TD900-TD910-TD920) you need to do it also on the Panel PC.
Premise: with this procedure all the PLC system variables and all the variables created and used on the
PLC are imported.
The list of PLC variables is created and updated only if the LogicLab program is compiled without
errors and downloaded on the target.
10.a
Creating a new Movicon project
Start the software and choose the “Windows® X86 / X64” platform for the Panel-PCs and “Windows® CE”
for the HMIs and for the “WEB” version PL500. If you are creating a new Movicon project following the
Wizard, at the end you will see a driver configuration window; go directly to the “Driver configuration”
section in par. 10.b. If you are installing the driver manually instead, follow the steps below.

Add the communication driver by right clicking
“Real time DB” and then “new communication
driver”.

Select “Pixsys” from the manufacturers menu
and then “SoftPLC Pixsys”.
Confirm with “OK” and double click the driver
just created to open the configuration window.

10.b

Driver configuration

Select the “Station” tab and add a new station
with the “ADD” button.
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1. Enter the source path of the LogicLab project in the PC with the development. This allows the
variable to be imported and run in Movicon preview mode on your development PC, including
checking communication with the SoftPLC. For this function, in the next step you need to state the
IP address of the terminal being programmed (only at the end of the development will you need
to enter the localhost address 127.0.0.1 to have the Movicon project communicate with the SoftPLC
residing in the same machine).
2. This field is self-compiled after entering the path of point 1. If you are using HMIs and the PL500, do
not change the self-compiled field, in case of Panel-PC (TD750-TD850-TD900 etc.) enter the path
where the project was downloaded (by default D:\LLExec\NomeMioProgettoLogicLab.sym.xml).
3. If the Movicon application is run in the Panel HMi or in the Panel-PC where also the SoftPLC is
present, enter IP address 127.0.0.1.
If, on the other hand, Movicon is run in a Panel HMi or Panel-PC other than that where the SoftPLC
resides, you must enter the IP address of the softPLC.
4. From the “General” section assign a name to the station, e.g.: “PLC”.
Press OK to save the settings and exit.
You can now import the variables of the
LogicLab project in Movicon.
Press the right key on “SoftPLC Pixsys” and select
“Import PLC database”.

Press “Read from PLC project” to get the list of
available variables.
Now select the variables you wish to import
and press “Import”.

NB: If you are importing an array type variable, this will be viewed as a structure that has the name of
the array. The single members of the array will be accessible individually with the syntax NomeMioArray:NomeMioArray _X where X is the index of the array (starting from 0).
The variables are now available in the Movicon project. If you need to import new variables, for example
in case of changes to the LogicLab project, only repeat the variable reading and import procedure.
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10.c
Transferring the Movicon code in the target
To transfer the Movicon project use the icon:

1. Select the transfer protocol: TCP
2. Enter the target IP address (default for HMI/
PLC: 192.168.0.100)
3. In case of HMI/PLC leave empty, in case of
Panel-PC enter user (or the name of the user
with which access to the Panel-PC target
was made).
4. In case of HMI/PLC leave empty, in case of
Panel-PC enter 123456
5. In case of HMI/PLC enter \NandFlash\NomeMioProgettoMovicon\, in case of Panel-PC
enter D:\NomeMioProgettoMovicon\.
Movicon will thus create a folder called
NomeMioProgettoMovicon and will
download all the project files within it.
6. Press “Transfer Project (Upload)!“ to start the
transfer (press “Yes to All“ in case a project
has been previously downloaded and you
wish to overwrite it).
NB: If you wish to transfer more than one different version/project, simply change the target folder
(in any case maintaining the first part \NandFlash\). From the TdControlPanel choose the project,
among those present in the device memory, to be started automatically when powering the target
(see paragraph 10.b).
7. Once the download procedure has been completed, press “Start Project on the Device!“ to have it run
on the target (the project being run will be terminated and the last transferred will be activated).

11

Simulating the entire project SoftPLC + SCADA

From LogicLab, launch the simulator from the
icon or from the “Debug” > “Simulation mode” menu.
In the window that appears create a new work area indicating the name and the target folder (the
folder where the project resides is selected by default).
At this point, the simulator will appear as started and connected (the status window will signal the
“CONNECTED” status) but without code (the status window will signal the “NO CODE” status), now
transfer the code pressing F5, through the
icon or from the “Online” > “Code transfer” menu.
Make sure that the status bar shows “CONNECTED” and “SOURCE OK”. If you still view “NO CODE”), restart
the simulator by pressing the
icon or from the “On-line” > “Target reboot” menu.
From Movicon, enter the Pixsys driver configuration window and configure as follows:
1. Enter the folder where the simulator is
working, set “All files (*.*) as filter for the
file type and select the file NomeMioProgettoLogicLab.sym.simul. Pay close
attention to the file extension since
many files with the same name but with
a different extension exist in the project
folder.
2. Enter the folder where the LogicLab
project resides and select the
NomeMioProgettoLogicLab.sym.xml
3. Set the localhost address: 127.0.0.1
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At this point, to launch the simulation of the graphic interface connected to the simulator (which is
already running the previously downloaded code) simply press the keys Alt+F12, the
icon or from
the “File” > “Start project” menu.
To end the simulation, press the keys Alt+F12 or the
icon in the bar at the top.

Limited liability

Pixsys S.r.l. guarantees its electronic equipment for a period of 12 months from the invoice date. The
Manufacturer’s liability is limited to repairing or replacing those parts that present manufacturing
defects or that are returned with RMA (Return Material Authorization). Pixsys declines any liability for
accidents and damage to people and objects deriving from tampering (including repairs attempted
by unauthorized personnel), unsuitable environmental conditions, incorrect installation, wrong,
improper use or use in any case non compliant with the characteristics of the instrument declared
in the technical documentation. In no case will the manufacturer’s liability exceed the value of the
instruments. The guarantee does not cover in any way the problems deriving from the installation
of software applications after the sale, and in particular the consequent damage from malware. Any
support interventions carried out by Pixsys to restore the operating system or the program will be
charged at the applicable support tariff.

Notes / Updates
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Read carefully the safety guidelines and programming instructions contained in
this manual before using/connecting the device.
Prima di utilizzare il dispositivo leggere con attenzione le informazioni di sicurezza
e settaggio contenute in questo manuale.
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